Формулы
До истечения срока действия
075
= A1-СЕГОДНЯ() Чтобы вычислить дни до истечения срока, вы можете использовать простую формулу, основанную на функции СЕГОДНЯ. В показанном примере формула
Формулы
Если понедельник, откат до пятницы
069
= ЕСЛИ(ДЕНЬНЕД(дата) = 2; дата-3; дата) Чтобы проверить день недели даты и откат до пятницы, когда дата — понедельник, вы можете использовать функции
Формулы
Дополнить номера недель с нулями
055
= ТЕКСТ (НОМНЕДЕЛИ (дата; тип); «00») Чтобы добавить номера недель (или любое число) нулями с помощью формулы, вы можете использовать функцию ТЕКСТ.
Формулы
Сумма промежутков времени
075
= СУММ (диапазон) Если вам нужно сложить (суммировать) промежуток времени, которые представляют собой комбинацию часов, минут и секунд, вы можете просто
Формулы
Разница во времени в часах как десятичное значение
086
= ОСТАТ(конечный старт; 1) * 24 Чтобы получить продолжительность между двумя значениями в десятичном часе (т. е. 3 часа, 4,5 часа, 8 часов и т.
Формулы
Всего часов, которые выпадают между двумя часами
064
= ЕСЛИ(начало <конец; МИН(конец; верхний) -МАКС(начало; нижний); МАКС(0; верхний старт) + МАКС(0; нижний конец)) У вас есть время начала и время окончания
Формулы
Рабочих дней в месяц
077
Для вычисления рабочих дней в месяц используйте функцию КОНМЕСЯЦА вместе с функцией ЧИСТРАБДНИ. В показанном примере формула в C4: = ЧИСТРАБДНИ(B4;
Формулы
Год — високосный год
0198
= МЕСЯЦ (ДАТА (ГОД (дата); 2;29)) = 2 Если вы хотите проверить, является ли год определенной даты високосным, вы можете использовать формулу, в которой