Условное форматирование уникальных значений

Условное форматирование уникальных значений

Общая формула

=СЧЁТЕСЛИ(данные;A1)=1

=COUNTIF(data,A1)=1

Объяснение

Примечание: Excel содержит множество встроенных правил для выделения значений с условным форматированием, включая правило, чтобы выделить ячейки, которые содержат уникальные значения. Однако, если вы хотите больше гибкости, вы можете использовать свою собственную формулу, как описано в этой статье.

Если вы хотите выделить ячейки, которые содержат уникальные значения в наборе данных, вы можете использовать формулу, которая возвращает ИСТИНА, когда значение появляется только один раз.

Например, если у вас есть значения в ячейках A1:D10 и вы хотите выделить ячейки с повторяющимися значениями, вы можете использовать следующую формулу:

=СЧЁТЕСЛИ($A$1:$D$10;A1)=1

=COUNTIF($A$1:$D$10,A1)=1

Важно, чтобы формула вводилась относительно выбранной «активной ячейки», которая в данном случае считается A1.

Как работает формула

СЧЁТЕСЛИ просто подсчитывает сколько раз, когда каждое значение появляется в диапазоне данных. По определению каждое значение должно появляться хотя бы один раз, поэтому, когда счетчик равен 1, значение уникально. Когда счетчик равен 1, формула возвращает ИСТИНА и запускает правило.

Условное форматирование вычисляется для каждой ячейки, к которой применяется. Когда вы используете формулу для применения условного форматирования, формула вычисляется относительно активной ячейки при выборе в момент создания правила. В этом случае диапазон, который мы используем в СЧЁТЕСЛИ, зафиксирован с абсолютным адресом, но A1 полностью относителен.

Итак, правило оценивается для каждой из 40 ячеек в A1:D10, а A1 будет обновляться до нового адреса 40 раз (один раз на ячейку), а $A$1:$D$10 остается неизменным.

Именованные диапазоны для более чистого синтаксиса

Другой способ зафиксировать ссылок — использовать именованные диапазоны, поскольку именованные диапазоны автоматически абсолютны. Например, если вы называете диапазон данных A1:D10 «данные», вы можете переписать правило на более простое:

=СЧЁТЕСЛИ(данные;A1)=1

=COUNTIF(data,A1)=1

Оцените статью
Добавить комментарий