Количество ячеек, которые начинаются с..

Определенного текста

=СЧЁТЕСЛИ(rng;»txt*»)

Для подсчета количества ячеек, которые начинаются с определенного текста, вы можете использовать функцию СЧЁТЕСЛИ. В общей форме формулы (выше) rng является диапазон ячеек, txt представляет собой текст, с которого клетки должны начинаться, и «*» является подстановочным соответствием с любым количеством символов.

Количество ячеек, которые начинаются с определенного текста

В примере, активная ячейка содержит следующую формулу:

=СЧЁТЕСЛИ(B5:B12;»app*»)

СЧЁТЕСЛИ подсчитывает количество ячеек в диапазоне, которые начинаются с TXT путем сопоставления содержимого каждой ячейки с шаблоном текста, который поставляется в качестве критерия. Символ «*» (звездочка) является подстановочным в Excel, что означает «совпадает с любым количеством символов». Количество ячеек, которые соответствуют этому шаблону возвращается как число.

С определенных цифр

=СУММПРОИЗВ(—(ЛЕВСИМВ(диапазон;символы)=»xx»))

Для подсчета чисел в диапазоне, которые начинаются с определенных номеров, вы можете использовать формулу, основанную на функции СУММПРОИЗВ и функции ЛЕВСИМВ.

Количество ячеек, которые начинаются с определенных цифр

В показанном примере, формула в Е4:

=СУММПРОИЗВ(—(ЛЕВСИМВ(B5:B11;2)=»25″))

Внутри СУММПРОИЗВ, мы используем функцию ЛЕВСИМВ на диапазоне чисел:

ЛЕВСИМВ(B5: B11;2)

Это создает массив результатов:

{ «25»; «25»; «35»; «45»; «25»; «45»; «25»}

Затем мы сравниваем каждое значение с «25», чтобы представить результат ИСТИНА или ЛОЖЬ. Обратите внимание, что ЛЕВСИМВ автоматически преобразует число в текст, поэтому мы используем текстовое значение «25» для сравнения. Результатом является массив истинных и ложных значений:

= СУММПРОИЗВ (— ({ИСТИНА; ИСТИНА; ЛОЖЬ; ЛОЖЬ; ИСТИНА; ЛОЖЬ; ИСТИНА}))

Далее, мы используем двойное отрицание, что превращает значения ИСТИНА, ЛОЖЬ в 1 и ноль, что создает числовой массив:

= СУММПРОИЗВ ({1; 1; 0; 0; 1; 0; 1})

Функция СУММПРОИЗВ затем просто суммирует элементы массива и рассчитывает 4.

Оцените статью
Добавить комментарий