Суммы с датами

Сумма, если Дата находится между двумя датами

=СУММЕСЛИМН(сумма;начальная_дата;»>»&А1;конечная_дата;»<«&В1)

В суммировании значений, которые находятся между двумя датами, можно использовать функцию СУММЕСЛИМН.

Сумма, если Дата находится между

В примере показано, ячейка H7 содержит формулу:

=СУММЕСЛИМН(D5:D11; C5:C11; «>15.07.2019»; C5:C11; «<15.08.2019»)

Эта формула суммирует суммы в столбце D, если Дата в столбце C между датой в Н5 и Н6. В примере, Н5 содержит 15 июля 2019 и H6 содержит 15 августа 2019.

Функция СУММЕСЛИМН поддерживает логические операторы Excel (т. е. «=»,»>»,»>=», и т. д.), и несколько критериев.

Чтобы соответствовать времени между двумя значениями, нам нужно использовать два критерия. СУММЕСЛИМН требует, чтобы каждому критерию вводился в качестве критерия/пара диапазон:

«>»&Н5;Дата // критерий 1

«<«&Н6;Дата // критерий 2

Обратите внимание, что мы должны заключить логические операторы в двойные кавычки ( «» ), а затем присоединиться с ссылками на ячейки с помощью амперсанда (&).

Если вы хотите включить Дату начала или окончания, а также сроки между ними, используйте больше или равно («>=») и меньше или равно («<=»).

Сумма, если Дата больше, чем

В сумме, если дата превышает определенную дату, вы можете использовать функцию СУММЕСЛИ.

Сумма, если Дата больше, чем

В примере показано, ячейка H4 содержит формулу:

=СУММЕСЛИ(C5:C11; «>1.10.2019»;D5:D11)

Эта формула суммирует суммы в столбце D, если Дата в столбце C больше 1 октября 2019 года.

Функция СУММЕСЛИ поддерживает логические операторы Excel (т. е. «=»,»>»,»>=», и т. д.), так что вы можете использовать их, как вам нравится в ваших критериях.

В данном случае, мы хотим чтобы дата была больше, чем 1 октября 2019 года, поэтому мы используем оператор больше чем (>).

Обратите внимание, что мы должны поставить оператор «больше, чем» в двойные кавычки и присоединить к нему амперсанд (&).

ДАТА как ссылка на ячейку

Если вы хотите выставить дату на листе, так что он может быть легко изменена, используйте эту формулу:

=СУММЕСЛИ(ДАТА;»>»&А1;сумма)

где A1-ссылка на ячейку, которая содержит действительную дату.

Альтернатива с СУММЕСЛИМН

Вы также можете использовать функцию СУММЕСЛИМН. СУММЕСЛИМН может обрабатывать несколько критериев, и порядок аргументов отличается от СУММЕСЛИ. Эквивалентная формула СУММЕСЛИМН:

=СУММЕСЛИМН(сумма; ДАТА;»>»&ДАТА(2019;10;1))

Обратите внимание, что диапазон суммирования всегда стоит первым в функции СУММЕСЛИМН.

Оцените статью
Добавить комментарий