Количество ячеек, которые не являются пустыми

=СЧЁТЗ(rng)

Для того, чтобы подсчитать количество ячеек, которые не являются пустыми, используйте функцию СЧЁТЗ. В общем виде формулы (выше) rng представляет собой диапазон ячеек.

Количество непустых ячеек

В примере, активная ячейка содержит следующую формулу:

=СЧЁТЗ(B5:B10)

СЧЁТЗ является полностью автоматической. Когда дается диапазон ячеек, она подсчитывает ячейки, которые содержат числа, текст, логические значения и ошибки. СЧЁТЗ не считает пустые ячейки.

Для подсчета ячеек, которые являются пустыми, вы можете использовать функцию СЧИТАТЬПУСТОТЫ следующим образом:

= СЧИТАТЬПУСТОТЫ (B5:B10)

Количество ячеек с одним символом и больше

Одна из проблем, с СЧЁТЗ является то, что она также будет считать пустые строки, возвращаемые формулами («»). Если вы столкнулись с этой проблемой, вы можете попробовать следующую формулу:

=СУММПРОИЗВ(—(ДЛСТР (A1:A100)>0))

Функция ДЛСТР возвращает количество символов, поэтому СУММПРОИЗВ будет рассчитывать только клетки, которые содержат хотя бы 1 символ.

Оцените статью
Добавить комментарий