Количество ячеек, которые заканчиваются на…

=СЧЁТЕСЛИ(rng;»*txt»)

Если вам нужно подсчитать количество ячеек заканчивающихся определенным текстом, вы можете легко сделать это с помощью функции СЧЁТЕСЛИ. В общей форме формулы (выше) rng представляет собой TXT текст, которым ячейки должны заканчиваться, и «*» является подстановочным знаком, соответствующим любому количеству символов.

Количество ячеек которые заканчиваются на определенный текст

В примере, ячейка E5, содержит следующую формулу:

=СЧЁТЕСЛИ(B5:B12;»*r»)

СЧЁТЕСЛИ подсчитывает количество ячеек в диапазоне, которые заканчиваются на «r», сопоставляя содержимое каждой ячейки с шаблоном «*r», который поставляется в качестве критерия. Символ «*» (звездочка) является подстановочным в Excel, что означает «совпадают с любым количеством символов». Количество ячеек, которые соответствуют этому шаблону рассчитываются как число.

Оцените статью
Добавить комментарий