Сумма по критериям

Сумма, если несколько критериев

=СУММЕСЛИМН(ранг_суммы; ранг_крит1 ; крит1 ; ранг_крит2 ; крит2)

Сумма, если несколько критериев

Если вам необходимо суммировать числа, основанные на нескольких критериях, вы можете использовать функцию СУММЕСЛИМН.

В показанном примере, формула в G5 является:

=СУММЕСЛИМН(D5:D12; B5:B12; «синий»; C5:C12; «>15»)

Первым диапазоном (D5: D12) являются ячейки суммы, называется «диапазон суммы».

Критерии поставляются в парах (диапазон / критериев).

Парой Первый критерий является (B5: B12 / «синий»). Это означает, что ячейки в B5: B12 должны быть равны «синий».

Пара Второй критерий представляет собой (C5: C12 / «> 15»). Ячейки в C5: C12 должны также быть> 15.

Эти ячейки в пределах суммы будут суммироваться только тогда, когда все критерии подходят.

Сумма, если один критерий в нескольких столбцах

=СУММПРОИЗВ((ранг_критериев= «красный» ) * ( суммарный_диапазон ))

Сумма, если один критерий в нескольких столбцах

Подсчитывая несколько столбцов условно, используя один или несколько критериев, вы можете использовать формулу, основанную на функции СУММПРОИЗВ. В показанном примере, формула в Н4:

=СУММПРОИЗВ(( B5: B10 = «красный» ) * ( С5: Е10 ))

Это первое выражение в СУММПРОИЗВ является критерием, проверяя, если клетки в B5: B10 содержат «красный». Результатом является массив значений ИСТИНА, ЛОЖЬ:

{ ИСТИНА ; ЛОЖЬ; ЛОЖЬ; ИСТИНА ; ЛОЖЬ; ЛОЖЬ}

Это значение умножается на значения в диапазоне С5: Е10:

{1;6;2; 8;6;8; 5;2;6; 2;6;7; 7;4;5; 5;3;1}

Результатом внутри СУММПРОИЗВ является:

= СУММПРОИЗВ ( { 1 ; 6 ; 2 ; 0 ; 0 ; 0 ; 0 ; 0 ; 0 ; 2 ; 6 ; 7 ; 0 ; 0 ; 0 ; 0 ; 0 ; 0 } )

который рассчитывает 24, сумма всех значений в С5: Е10, где B5: B10 = «красный».

Сумма, если равно одному из нескольких критериев

=СУММПРОИЗВ (СУММЕСЛИ ( диапазон_условия ; условие ; диапазон_суммирования ))

Сумма, если равно одному из нескольких критериев

В показанном примере, формула в Н4:

=СУММПРОИЗВ(СУММЕСЛИ(B5:B11; E5:E7; C5:C11))

Функция СУММЕСЛИ принимает три аргумента: диапазон, критерии и суммарный_диапазон.

Для диапазона, мы используем B5: B11. Эти ячейки содержат значения, которые мы тестируем по нескольким критериям.

Для критериев, мы используем именованный диапазон «вещи» (E5: E7). Этот диапазон содержит 3 значения, которые мы используем в качестве критерия. Этот диапазон может быть расширен за счет включения дополнительных критериев, по мере необходимости.

Для суммарного_диапазона, мы используем C5: C11, который содержит числовые значения.

Потому как мы даем СУММЕСЛИ более чем один критерий, он будет рассчитывать несколько результатов — один результат для каждого значения в «вещи». Результаты рассчитываются в массиве следующим образом:.

=СУММПРОИЗВ( { 60 ; 30 ; 12 } )

СУММПРОИЗВ затем суммирует все элементы в массиве и рассчитывает конечный результат, 102.

Оцените статью
Добавить комментарий